BG Development


Страници: (15) 1 2 [3] 4 5 ... последна »  ( Първото ново мнение ) Reply to this topicStart new topicStart Poll

> Oтворена дискусия за миграцията на форума
ProXy
Публикувано на: 15-03-2018, 13:25
Quote Post



Име: Йордан Иванов
Група: Потребител
Ранг: Почетен член

Мнения: 1626
Регистриран на: 25.01.10



Аз също смятам, че вдигането на нова версия на IPB ще доведе до проблеми. За смяната на софтуера да не говорим. Няколко медия куерита, които да направят форума по-използваем на мобилни устройства би трябвало да са повече от достатъчни.

Ако все пак се прибегне до миграция предложенията ми са следните:
- API Rest/GraphQL (лично аз съм голям фен на второто)
- Старият форум да си остане read-only на отделен под-домейн поне половин-една година след пускане на първият.
- Да се мигрира следното: Потребители (никове, имена, имейли, дати на регистрация), мнения, лични съобщения.
- Вместо да ползваме същите пароли да се разпратят мейли с нови генерирани пароли, които да ползват по-добро криптиране.
- Потребители с малко мнения, регистрирани преди повече от година няма да получат нова парола, освен, ако не си поискат или не използват "забравена парола".
- За самата миграция да се ползва единен начин на тестване (docker, vagrant, etc), който да даде малко по-добра консистентност м/у мигриращите и продукция
- Скрито хранилище за "скриптовете", които ще се ползват за миграция.


--------------------
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live.

https://www.ivanovyordan.com/
PMEmail PosterUsers Website
Top
Gamma Goblin
Публикувано на: 15-03-2018, 13:26
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 1954
Регистриран на: 21.02.18



QUOTE (samominavam @ 15-03-2018, 13:24)
QUOTE (Gamma Goblin @ 15-03-2018, 13:21)
QUOTE (samominavam @ 15-03-2018, 13:14)
Типичните програмисти - празни приказки само.
Вместо да се направи една миграция към да кажем phpBB3 - работа за няколко часа се разпъват локуми и всеки гледа си наложи неговата глупава идея..

еми айде миграрй го, стига си разтягал локуми

Сори, не съм богоизбран.

искаш да кажеш “слънцеизбран“


--------------------
https://www.rust-lang.org/
---
Недобросъвестните оратори се опитват да изкарат лошото добро.
---
PMEmail PosterUsers Website
Top
Gamma Goblin
Публикувано на: 15-03-2018, 13:28
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 1954
Регистриран на: 21.02.18



QUOTE
GraphQL
bitch please


--------------------
https://www.rust-lang.org/
---
Недобросъвестните оратори се опитват да изкарат лошото добро.
---
PMEmail PosterUsers Website
Top
lucky
Публикувано на: 15-03-2018, 14:42
Quote Post



Име:
Група: Потребител
Ранг: Старо куче

Мнения: 719
Регистриран на: 05.08.17



все щях да пускам тема за graphQLa. Някой ползвал ли го е продъкшън, става ли за нещо или е само вятър работа?
PMEmail Poster
Top
Gamma Goblin
Публикувано на: 15-03-2018, 14:43
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 1954
Регистриран на: 21.02.18



QUOTE (lucky @ 15-03-2018, 14:42)
все щях да пускам тема за graphQLa. Някой ползвал ли го е продъкшън, става ли за нещо или е само вятър работа?

без да ми осираш темата моля. отвори си друга


--------------------
https://www.rust-lang.org/
---
Недобросъвестните оратори се опитват да изкарат лошото добро.
---
PMEmail PosterUsers Website
Top
hristonev
Публикувано на: 15-03-2018, 14:51
Quote Post



Име:
Група: Потребител
Ранг: Редовен член

Мнения: 435
Регистриран на: 19.09.17



Реално толкова стара система е леко безумно да хвърляш усилия в модернизиране на фронтенда. Ако има платформи с АПИ бекенд то това си е много яка алтернатива. Иначе не съм наясно с тези платформи icon_smile.gif и не мога да дам компетентно мнение.
PMEmail Poster
Top
lucky
Публикувано на: 15-03-2018, 15:54
Quote Post



Име:
Група: Потребител
Ранг: Старо куче

Мнения: 719
Регистриран на: 05.08.17



QUOTE (Gamma Goblin @ 15-03-2018, 14:43)

без да ми осираш темата моля. отвори си друга

мързи ме бе! Сън, ще форкнеш ли поста? icon_lol.gif
PMEmail Poster
Top
erazor
Публикувано на: 15-03-2018, 17:14
Quote Post



Име: Димитър
Група: Потребител
Ранг: Старо куче

Мнения: 629
Регистриран на: 26.06.07



Според мен разумната причина за ъпдейт на платформата е, за да се ползва нещо което работи на съвременна и поддържана версия на езика (PHP)
Форума e © 2003, писан за PHP 4, което не се подържа официално от 2008-ма (http://php.net/eol.php)

Затова и като се смени хостинга, на такъв който не поддържа PHP4, имаше проблеми..

В момента най-вероятно форума работи на PHP 5.x което се очаква да има активна поддържка до края на годината (http://php.net/supported-versions.php)
Тук вече миграцията на нещо писано на PHP 4, към PHP 7.x ще създаде доста повече проблеми ако е възможно въобще.

PMEmail PosterICQ
Top
reason
Публикувано на: 15-03-2018, 19:12
Quote Post



Име:
Група: Потребител
Ранг: Редовен член

Мнения: 408
Регистриран на: 24.05.05



Значи има време до като се спре поддръжката на пхп 5.х , спокойни сме, няма да се бърза icon_lol.gif

Това мнение е било редактирано от reason на 15-03-2018, 19:13
PMEmail Poster
Top
SuN
Публикувано на: 15-03-2018, 19:28
Quote Post


Group Icon
Име:
Група: Администратор
Ранг: Почетен член

Мнения: 7995
Регистриран на: 27.01.05



Аз мисля, че е редно да се ползва поне версия 7 или 8, а май и 9 излезе наскоро. Уж било по-бързо от преди и ще станем "еко-форум".

П.П.
Джон, ти имаш ли сертификат, че форума ти е "Eco-friendly" ?icon_smile.gif Може да си го измислиш сам и да си го лепнеш.
PMEmail Poster
Top
0 потребители преглеждат тази тема в момента (0 гости, 0 анонимни потребители)
Потребители, преглеждащи темата в момента:

Topic Options Страници: (15) 1 2 [3] 4 5 ... последна » Reply to this topicStart new topicStart Poll

 


Copyright © 2003-2019 | BG Development | All Rights Reserved
RSS 2.0