BG Development


  Reply to this topicStart new topicStart Poll

> Ubuntu 18.04 - Проблем с инсталация на Thumbor
miss
Публикувано на: 06-03-2019, 23:14
Quote Post



Име:
Група: Потребител
Ранг: Новопостъпил

Мнения: 27
Регистриран на: 14.04.15



Опитвам се да инсталирам thumbor на сървър с Linux Ubuntu 18.04:
CODE
pip install --user thumbor


Получавам грешка:
user posted image

Потърсих в интернет и пробвах решенията, които са преложени там, но нищо не помага, продължавам да получавам същия Error. Някой може ли да обясни на какво се дължи той и евентуално да преложи решение, което работи?

Благодаря!

Това мнение е било редактирано от miss на 06-03-2019, 23:16
PMEmail Poster
Top
Gamma Goblin
Публикувано на: 07-03-2019, 06:45
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2096
Регистриран на: 21.02.18



това е питон и няма общо с линукс - питаш в грешния раздел

иначе пробвай да си инсталираш кърл: sudo apt-get install curl

Това мнение е било редактирано от Gamma Goblin на 07-03-2019, 06:46


--------------------
https://www.rust-lang.org/
---
Недобросъвестните оратори се опитват да изкарат лошото добро.
---
PMEmail PosterUsers Website
Top
bvbfan
Публикувано на: 07-03-2019, 07:06
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3070
Регистриран на: 08.12.13



Пробвай да го инсталираш глобално, това едно от нещата, което трябва да се специфицира по-добре, някои инсталации като user не работят, други работят, но след това получаваш не работещ изпълним файл.


--------------------
QUOTE (Bender @ 23-04-2015, 19:11)
Xamarin: ЛАПАЙ!
Ти: Добре...
PMEmail Poster
Top
miss
Публикувано на: 07-03-2019, 10:29
Quote Post



Име:
Група: Потребител
Ранг: Новопостъпил

Мнения: 27
Регистриран на: 14.04.15



И двете не работят, пробвал съм ги.
CODE
curl is already the newest version (7.58.0-2ubuntu3.6).


Това мнение е било редактирано от miss на 07-03-2019, 10:32
PMEmail Poster
Top
Gamma Goblin
Публикувано на: 07-03-2019, 11:31
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2096
Регистриран на: 21.02.18



ами виж имаш ли curl-config, ако нямаш: apt-cache search curl-config
и после инсталираш съответния пакет

Това мнение е било редактирано от Gamma Goblin на 07-03-2019, 11:33


--------------------
https://www.rust-lang.org/
---
Недобросъвестните оратори се опитват да изкарат лошото добро.
---
PMEmail PosterUsers Website
Top
ici
Публикувано на: 07-03-2019, 11:39
Quote Post


Group Icon
Име: Ивайло Илчев ики
Група: VIP
Ранг: Почетен член

Мнения: 16122
Регистриран на: 06.06.04



По-скоро подoбно нещо трябва да има в libcurl-xxx-dev https://packages.ubuntu.com/trusty/libcurl-dev. icon_idea.gif


--------------------
Reading undefined locations provides undefined data.
PMEmail PosterUsers Website
Top
bvbfan
Публикувано на: 07-03-2019, 15:23
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3070
Регистриран на: 08.12.13



При мен не иска нищо
CODE

[toni@toni-pc ~]$ pip3 install --user thumbor
Collecting thumbor
Downloading https://files.pythonhosted.org/packages/a5/7d/75844134e7c1a2a7550195a5461a84b1230e42d1bc72e8574694694dfd34/thumbor-6.7.0.tar.gz (1.1MB)
100% |████████████████████████████████| 1.1MB 7.9MB/s
Collecting tornado<6.0.0,>=4.1.0 (from thumbor)
Downloading https://files.pythonhosted.org/packages/e6/78/6e7b5af12c12bdf38ca9bfe863fcaf53dc10430a312d0324e76c1e5ca426/tornado-5.1.1.tar.gz (516kB)
100% |████████████████████████████████| 522kB 13.3MB/s
Collecting pycryptodome>=3.4.7 (from thumbor)
Downloading https://files.pythonhosted.org/packages/9e/55/038b18574705a86548e0008e4ea88a80393a370068e8a67c28becf2f4865/pycryptodome-3.7.3-cp37-cp37m-manylinux1_x86_64.whl (7.5MB)
100% |████████████████████████████████| 7.5MB 3.8MB/s
Collecting pycurl<7.44.0,>=7.19.0 (from thumbor)
Downloading https://files.pythonhosted.org/packages/e8/e4/0dbb8735407189f00b33d84122b9be52c790c7c3b25286826f4e1bdb7bde/pycurl-7.43.0.2.tar.gz (214kB)
100% |████████████████████████████████| 215kB 769kB/s
Collecting Pillow<6.0.0,>=4.3.0 (from thumbor)
Downloading https://files.pythonhosted.org/packages/ae/2a/0a0ab2833e5270664fb5fae590717f867ac6319b124160c09f1d3291de28/Pillow-5.4.1-cp37-cp37m-manylinux1_x86_64.whl (2.0MB)
100% |████████████████████████████████| 2.0MB 2.7MB/s
Collecting derpconf>=0.2.0 (from thumbor)
Downloading https://files.pythonhosted.org/packages/6f/34/9277afa018c59861c5c1e6455a27866ab6475f4820b09cea22a02c15e4fa/derpconf-0.8.3.tar.gz
Collecting piexif<2.0.0,>=1.0.13 (from thumbor)
Downloading https://files.pythonhosted.org/packages/d9/45/19726eac3f8ddedccff86de92fa6d16d90b0e9257df811b7331f0b91d966/piexif-1.1.2-py2.py3-none-any.whl
Collecting statsd>=3.0.1 (from thumbor)
Downloading https://files.pythonhosted.org/packages/47/33/c824f799128dfcfce2142f18d9bc6c55c46a939f6e4250639134222d99eb/statsd-3.3.0-py2.py3-none-any.whl
Collecting libthumbor>=1.3.2 (from thumbor)
Downloading https://files.pythonhosted.org/packages/99/db/28a9bc9088de0971b0a20cd041f3e65fe03e7e303d627de2077a9b7151ee/libthumbor-1.3.2.tar.gz
Collecting futures (from thumbor)
Downloading https://files.pythonhosted.org/packages/cc/26/b61e3a4eb50653e8a7339d84eeaa46d1e93b92951978873c220ae64d0733/futures-3.1.1.tar.gz
Collecting argparse (from thumbor)
Downloading https://files.pythonhosted.org/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting pytz (from thumbor)
Downloading https://files.pythonhosted.org/packages/61/28/1d3920e4d1d50b19bc5d24398a7cd85cc7b9a75a490570d5a30c57622d34/pytz-2018.9-py2.py3-none-any.whl (510kB)
100% |████████████████████████████████| 512kB 2.8MB/s
Requirement already satisfied: six in /usr/lib/python3.7/site-packages (from thumbor) (1.12.0)
Collecting webcolors (from thumbor)
Downloading https://files.pythonhosted.org/packages/1d/44/c4902683be73beba20afd299705e11f0a753a01cc7f9d6a070841848605b/webcolors-1.8.1-py2.py3-none-any.whl
Installing collected packages: tornado, pycryptodome, pycurl, Pillow, derpconf, piexif, statsd, libthumbor, futures, argparse, pytz, webcolors, thumbor
Running setup.py install for tornado ... done
Running setup.py install for pycurl ... done
Running setup.py install for derpconf ... done
Running setup.py install for libthumbor ... done
Running setup.py install for futures ... done
Running setup.py install for thumbor ... done
Successfully installed Pillow-5.4.1 argparse-1.4.0 derpconf-0.8.3 futures-3.1.1 libthumbor-1.3.2 piexif-1.1.2 pycryptodome-3.7.3 pycurl-7.43.0.2 pytz-2018.9 statsd-3.3.0 thumbor-6.7.0 tornado-5.1.1 webcolors-1.8.1


Edit:
Аз си пиша експлицитно да си ползва Python3, новите пакети го изискват.

Това мнение е било редактирано от bvbfan на 07-03-2019, 15:26


--------------------
QUOTE (Bender @ 23-04-2015, 19:11)
Xamarin: ЛАПАЙ!
Ти: Добре...
PMEmail Poster
Top
1 потребители преглеждат тази тема в момента (1 гости, 0 анонимни потребители)
Потребители, преглеждащи темата в момента:

Topic Options Reply to this topicStart new topicStart Poll

 


Copyright © 2003-2019 | BG Development | All Rights Reserved
RSS 2.0