BG Development


  Reply to this topicStart new topicStart Poll

> проблем yarn
Constantine
Публикувано на: 04-07-2024, 16:33
Quote Post



Име: Константин К
Група: Потребител
Ранг: Активен

Мнения: 225
Регистриран на: 13.04.05



Здравейте

имам проблем с yarn

конзола: yarn install

node: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by node)

Някой може ли да даде едно рамо

Хубав ден
PMEmail PosterUsers Website
Top
Constantine
Публикувано на: 04-07-2024, 16:41
Quote Post



Име: Константин К
Група: Потребител
Ранг: Активен

Мнения: 225
Регистриран на: 13.04.05



Успях да подкарам yarn - версия 1.22.22

Сега при yarn install излиза грешка:
error vite@5.3.3: The engine "node" is incompatible with this module. Expected version "^18.0.0 || >=20.0.0". Got "16.15.1"
error Found incompatible module.

PMEmail PosterUsers Website
Top
akrachev
Публикувано на: 04-07-2024, 21:02
Quote Post



Име: акрачев
Група: Потребител
Ранг: Почетен член

Мнения: 1073
Регистриран на: 27.11.09



да сложиш нова весрия на Node?


--------------------
PMEmail PosterUsers Website
Top
Constantine
Публикувано на: 05-07-2024, 10:26
Quote Post



Име: Константин К
Група: Потребител
Ранг: Активен

Мнения: 225
Регистриран на: 13.04.05



ъпдейтнах до v17.9.1

error @csstools/selector-specificity@2.2.0: The engine "node" is incompatible with this module. Expected version "^14 || ^16 || >=18". Got "17.9.1"

В кръг започвам да се въртя
PMEmail PosterUsers Website
Top
thrawn
Публикувано на: 05-07-2024, 12:05
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3679
Регистриран на: 17.01.17



Добре де, node.js е на версия 22, пише ти да ползваш по-голяма от 18-та а ти инсталираш 17-та?
PMEmail Poster
Top
Bender++
Публикувано на: 05-07-2024, 16:36
Quote Post



Име:
Група: Потребител
Ранг: Редовен член

Мнения: 543
Регистриран на: 18.04.21



JS-a e престъпление срещу човечеството icon_sad.gif


--------------------
Слава на Цар Путин! Долу украинските фашисти!
PMEmail Poster
Top
relax4o
Публикувано на: 06-07-2024, 13:24
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2825
Регистриран на: 04.04.07



QUOTE (Constantine @ 05-07-2024, 10:26)
ъпдейтнах до  v17.9.1

error @csstools/selector-specificity@2.2.0: The engine "node" is incompatible with this module. Expected version "^14 || ^16 || >=18". Got "17.9.1"

В кръг започвам да се въртя

Очевидно не можеш да интерпретираш какво ти казва грешката.

QUOTE

"^18.0.0 || >=20.0.0". Got "16.15.1"


Трябва ти версия на Node 18.x ИЛИ по-голяма или равна на 20.0.0.

QUOTE

"^14 || ^16 || >=18". Got "17.9.1"


Трябва ти версия 14.x.x ИЛИ 16.х.x ИЛИ по-голяма или равна от 18.0.0. ^ модификатора индикира, че изисква версия с конкретна MAJOR версия, в случая, които са 14 и 16, но няма претенции коя MINOR и PATCH версия е.

Предвид тази информация, ти се казва, че версия 17 не е една от поддържаните. В никакъв случай не си мисли, че ^16 означава, че включва и версия 17.

Формат на версиите: <MAJOR>.<MINOR>.<PATCH>.

Сложи си fnm или nvm и инсталирай, която искаш версия на Node.

https://semver.org/

Това мнение е било редактирано от relax4o на 06-07-2024, 13:26


--------------------
Бисери :D

QUOTE (oveRLuckEd)
Ползваш някоя нова версия на PHP, която е вече ооп ориентирана и заради това ти я изкарва тази грешка.


QUOTE (nbacool2)
Щом няма input полета, значи няма откъде да се направи SQL инжекция Very Happy
PM
Top
Constantine
Публикувано на: 11-07-2024, 09:57
Quote Post



Име: Константин К
Група: Потребител
Ранг: Активен

Мнения: 225
Регистриран на: 13.04.05



Има ли някой който разбира от docker ?

Идеята е да се пусне през docker

PMEmail PosterUsers Website
Top
Lachezar
Публикувано на: 12-07-2024, 10:56
Quote Post



Име: Лъчезар Добрев
Група: Потребител
Ранг: Почетен член

Мнения: 2783
Регистриран на: 10.11.04



CODE
docker run --rm -it --volume $(pwd):/project --user $(id -u):$(id -g) --workdir /project node:18-alpine yarn install


--------------------
И'м ватцхинг ъоу...
PMUsers Website
Top
1 потребители преглеждат тази тема в момента (1 гости, 0 анонимни потребители)
Потребители, преглеждащи темата в момента:

Topic Options Reply to this topicStart new topicStart Poll

 


Copyright © 2003-2019 | BG Development | All Rights Reserved
RSS 2.0