BG Development


Страници: (2) [1] 2   ( Първото ново мнение ) Reply to this topicStart new topicStart Poll

> как правилно се ъпдейтва пакет от testing?, debian
Demigod
Публикувано на: 28-04-2019, 09:24
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 4370
Регистриран на: 26.04.09



от стабилното репоситори на debian питоня е с версия 2.7 (имам го вече инсталиран). Обаче за определен софтуер ми тряа минимум 3.6. Добавям "testing" репоситорито в sources, и инсталирам питоня от там.

CODE
sudo apt-get -t testing install python


инсталира допълнително 10000 неща тая команда, рестартирам и ме посреща терминал:

CODE
Debian GNU/Linux 9 debian tty1
debian login:_


Добре че имам акъл да го backup-на виртуалката преди да тръгна да я правя тая процедура, подозирайки какви лайна ще се случат щом направя съвсем малка стъпка отвъд елементарната употреба на системата.

Ай да ми обясните сега колко съм некадърен и как тая операционна система става за обикновени десктоп потребители.

Нека позная, защото съм имал съществуващ питон 2.7, като инсталирам "python" от тестинг се опитва да update-не абсолютно всички пакети които зависят от съществуващата версия на питоня от testing ли ?

Това мнение е било редактирано от Demigod на 28-04-2019, 09:30


--------------------
being insane is so .... liberating ....
PMEmail Poster
Top
Gamma Goblin
Публикувано на: 28-04-2019, 09:30
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2256
Регистриран на: 21.02.18



Билдни си го от сорс https://www.rosehosting.com/blog/how-to-ins...-4-on-debian-9/

ама не преави make install, защото ти копира някакви файлове някъде си, които посл еням акак да махнеш

Това мнение е било редактирано от Gamma Goblin на 28-04-2019, 09:31


--------------------
https://www.rust-lang.org/
---
Хора, които са прекалено умни, за да се занимават с политика, са наказани да бъдат управлявани от глупаци.
---
PMEmail PosterUsers Website
Top
thrawn
Публикувано на: 28-04-2019, 09:31
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2232
Регистриран на: 17.01.17



Докато ползва прозорци не ти беше проблем да сваляш и инсталираш приложенията ръчно...
Колкото и да е готино да ползваш глезотиите, понякога се налага да инсталираш приложенията и по старо модния начин.
Сваляш си деб файлчето и си го инсталираш ръчно.

Другия вариант е да търсиш хранилище само с това което ти трябва.
PMEmail Poster
Top
bvbfan
Публикувано на: 28-04-2019, 09:37
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3144
Регистриран на: 08.12.13



Нямам идея защо правиш глупости, сваляш сорса на 3.6 и си го компилираш и инсталираш

CODE
sudo apt-get install build-essential checkinstall libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev
wget https://www.python.org/ftp/python/3.7.3/Python-3.7.3.tgz
tar xzf Python-3.7.3.tgz
cd Python-3.7.3
./configure --enable-optimizations -prefix=${HOME}/python3.7
make && make install


--------------------
QUOTE (Bender @ 23-04-2015, 19:11)
Xamarin: ЛАПАЙ!
Ти: Добре...
PMEmail Poster
Top
purjola
Публикувано на: 28-04-2019, 10:43
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2332
Регистриран на: 18.10.11



QUOTE (Demigod @ 28-04-2019, 10:24)
от стабилното репоситори на debian питоня е с версия 2.7 (имам го вече инсталиран). Обаче за определен софтуер ми тряа минимум 3.6. Добавям "testing" репоситорито в sources, и инсталирам питоня от там.

CODE
sudo apt-get -t testing install python


инсталира допълнително 10000 неща тая команда, рестартирам и ме посреща терминал:

CODE
Debian GNU/Linux 9 debian tty1
debian login:_


Добре че имам акъл да го backup-на виртуалката преди да тръгна да я правя тая процедура, подозирайки какви лайна ще се случат щом направя съвсем малка стъпка отвъд елементарната употреба на системата.

Ай да ми обясните сега колко съм некадърен и как тая операционна система става за обикновени десктоп потребители.

Нека позная, защото съм имал съществуващ питон 2.7, като инсталирам "python" от тестинг се опитва да update-не абсолютно всички пакети които зависят от съществуващата версия на питоня от testing ли ?

Айде да не е точно така. Пакетът е python3, тоест:

CODE
apt-get update
apt-get -y upgrade
apt-get install -y python3
PMEmail Poster
Top
samominavam
Публикувано на: 28-04-2019, 15:47
Quote Post



Име:
Група: Потребител
Ранг: Редовен член

Мнения: 303
Регистриран на: 22.08.17



QUOTE (bvbfan @ 28-04-2019, 09:37)
Нямам идея защо правиш глупости, сваляш сорса на 3.6 и си го компилираш и инсталираш

CODE
sudo apt-get install build-essential checkinstall libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev
wget https://www.python.org/ftp/python/3.7.3/Python-3.7.3.tgz
tar xzf Python-3.7.3.tgz
cd Python-3.7.3
./configure --enable-optimizations -prefix=${HOME}/python3.7
make && make install

Ако го нямаше копи/пейста нямаше да го има и линукса хахах
PMEmail Poster
Top
gat3way
Публикувано на: 28-04-2019, 22:35
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3862
Регистриран на: 22.06.12



Да не повярва човек, дотук единствено пържолата даде верен отговор, почти верен де, apt-get upgrade е тотално безсмислена операция и най-много да създаде ядове. А пък да си билдваш питона от сорс...ибахмааму.
PMEmail Poster
Top
purjola
Публикувано на: 28-04-2019, 23:25
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 2332
Регистриран на: 18.10.11



QUOTE (gat3way @ 28-04-2019, 23:35)
Да не повярва човек, дотук единствено пържолата даде верен отговор, почти верен де, apt-get upgrade е тотално безсмислена операция и най-много да създаде ядове. А пък да си билдваш питона от сорс...ибахмааму.

Винаги upgrade, всяко счупено нещо ми е забавление icon_lol.gif
PMEmail Poster
Top
gat3way
Публикувано на: 29-04-2019, 00:21
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3862
Регистриран на: 22.06.12



Ако все пак някои неща ги билдваш от сорс щото имаш работа по тях или щото ги няма из репотата, тоя ъпгрейд чат-пат се случва много добре да ти излезе през носа. Ама то няма угодия, дебианския начин е да hold-ваш пакети така че да не се ъпгрейдват, това винаги работи известно време и след това пак ти излиза през носа.
PMEmail Poster
Top
bvbfan
Публикувано на: 29-04-2019, 08:17
Quote Post



Име:
Група: Потребител
Ранг: Почетен член

Мнения: 3144
Регистриран на: 08.12.13



Когато ползваш fixed release дистро, като Дебиан, е най-добре да си компилираш всичко, което не е хранилището, тъй като не ползвам Дебиан, предположих, че може да не са минали на 3.6 (пък и 3.7 е актуалният)


--------------------
QUOTE (Bender @ 23-04-2015, 19:11)
Xamarin: ЛАПАЙ!
Ти: Добре...
PMEmail Poster
Top
0 потребители преглеждат тази тема в момента (0 гости, 0 анонимни потребители)
Потребители, преглеждащи темата в момента:

Topic Options Страници: (2) [1] 2  Reply to this topicStart new topicStart Poll

 


Copyright © 2003-2019 | BG Development | All Rights Reserved
RSS 2.0